Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
santilo1
06.06.2023 02:22 •
Информатика
Сpython (функция def)
что не так? дается написать одно число, а потом вылазит ошибка об не существовании "с1"
Показать ответ
Ответ:
азат61
11.07.2022 04:40
1)
#include <iostream>
#include <conio.h>
#include <string>
using namespace std;
int main()
{
string str;
getline(cin, str);
for (int i = 1; i < str.length(); i++)
{
if (i % 3 == 0)
{cout << str[i] << endl;}
}
_getch();
return 0;
}
2)
#include <iostream>
#include <conio.h>
#include <string>
using namespace std;
int main()
{ string str;
getline(cin, str);
for (int i = 1; i < str.length(); i++)
{
if (i % 2 == 0)
{ if (str[i] != 'a')
{ str[i] = 'a'; }
if (str[i] != 'b')
{ str[i] = 'b'; }
if (str[i] != 'c')
{ str[i] = 'c'; }
}
}
cout << str << endl;
_getch();
return 0;}
0,0
(0 оценок)
Ответ:
dariadarina1
29.11.2021 05:39
1.
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32
2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт
3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16
4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит
8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт
0,0
(0 оценок)
Популярные вопросы: Информатика
polinasenchenk
07.01.2021 11:22
Айжан решила нарисовать векторное изображение. ей выбрать инструмент для преобразования фигуры....
Killy2
16.08.2021 23:47
Умоляю. кто написал кит 6-7 классы надо....
Мираж005
16.08.2021 23:47
Незнайка решивший написатьнезнайка решивший написать стихотворение в редакторе блокнот нажимал клавиши как показано ниже.в результате первые буквы текста выглядели как че...
dasha8743
20.10.2021 05:39
Написать на паскале. решить надо с цикла for. вывести на экран все делители данного числа введенного с клавиатуры....
Хэлпер228666
20.10.2021 05:39
Напишите программу вычисляющую площадь квадрата. стороны пользователь вводит с клавиатуры...
rsharapov
05.02.2020 05:50
Какие виды графики вы знаете?что изображено на рисунках? чем они отличаются от 2d изображений...
alenaFox457
09.06.2022 03:10
Тізімнен интернетке тәуелділіктің бір белгісін таңда: Виртуалды әлемде ұзақ уақыт өткізуҮй тапсырмасын online режимінде орындауЖергілікті желі бойынша қажетті ақпаратты іздеуОффлайн...
Sasha080903
26.10.2020 14:57
5 терабайтты есептеу үшін дұрыс формула танда...
afanasevaboom123
21.12.2022 09:27
Дан символ C — строчная (маленькая) русская буква и текстовый файл. Создать строковый файл и записать в него все слова из исходного файла, содержащие хотя бы одну букву C...
isanatoliy25199
11.05.2021 18:32
З міста в село Простоквашино виїхав разом з батьками на автомобілі дядя Федір. Коли вони із середньою швидкістю 80 км/год проїхали 3 години, то прокололи шину. Із села Простоквашино...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream>
#include <conio.h>
#include <string>
using namespace std;
int main()
{
string str;
getline(cin, str);
for (int i = 1; i < str.length(); i++)
{
if (i % 3 == 0)
{cout << str[i] << endl;}
}
_getch();
return 0;
}
2)
#include <iostream>
#include <conio.h>
#include <string>
using namespace std;
int main()
{ string str;
getline(cin, str);
for (int i = 1; i < str.length(); i++)
{
if (i % 2 == 0)
{ if (str[i] != 'a')
{ str[i] = 'a'; }
if (str[i] != 'b')
{ str[i] = 'b'; }
if (str[i] != 'c')
{ str[i] = 'c'; }
}
}
cout << str << endl;
_getch();
return 0;}
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32
2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт
3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16
4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит
8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт