В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
RoyaIHeII
RoyaIHeII
22.06.2020 10:15 •  Информатика

Среди чисел 1,4,9,16,25...найти первое число,меньшее n. n ввести с клавиатуры
паскаль

Показать ответ
Ответ:
Albert116
Albert116
10.03.2020 16:03

var j, a, b, n: integer;

label 1;

begin

1: randomize;

  a: = random (9);

  b: = random (9);

  write (a, '*', b, '=');

  read (n);

  if n = (a * b) then writeln ('відповідь вірний! ')

            else writeln ('відповідь неправильний! ');

  writeln ('продовжуватимеш? ');

  writeln ('якщо так то натисни 1');

  writeln ('якщо немає то натисни 2');

  read (j);

  if j = 1 then goto 1;

  if j = 2 then writeln ('до побачення! ');

end.

начебто так, точно не пам'ятаю.

0,0(0 оценок)
Ответ:
saraikinacaterina
saraikinacaterina
17.03.2021 19:59

1)

var

a: integer;

even,odd: byte;

begin

readln(a);

even := 0;

odd := 0;

while a > 0 do begin

 if (a mod 2) = 0 then

  even := even + 1

 else

  odd := odd + 1;

 a := a div 10;

end;

writeln('even: ', even);

writeln('odd: ', odd);

end.

2)

var

   n, m: longint;

   a: byte;

begin

   readln(n);

   m := 0;

   while n>0 do begin

       a := n mod 10;

       n := n div 10;

       m := m*10 + a;

   end;

   writeln(m);

readln;

end.

3)

var

   a,b,c,i,n: integer;

begin

   write('n = ');

   readln(n);

   a := 0;

   write(a,' ');

   b := 1;

   write(b,' ');

   for i:=3 to n do begin

       write(a+b,' ');

       c := b;

       b := a + b;

       a := c

   end;

readln

end.

Объяснение:


Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота