Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
сказка500
06.01.2020 06:42 •
Информатика
"среди чисел a,b,c,d найти сумму целых чисел " составьте программу по этой на pascal abc
Показать ответ
Ответ:
саша4275
04.10.2020 20:42
Var
a,b,c,d:real;
s:integer;
begin
Write('Введите a b c d: '); Read(a,b,c,d);
if frac(a)=0 then s:=Trunc(a) else s:=0;
if frac(b)=0 then s:=s+Trunc(b);
if frac(c)=0 then s:=s+Trunc(c);
if frac(d)=0 then s:=s+Trunc(d);
Writeln('S=',s)
end.
Пример
Введите a b c d: 2.5 6 -3 -1.75
S=3
0,0
(0 оценок)
Популярные вопросы: Информатика
87056231946
25.01.2020 06:01
Запиши число 13477 в развёрнутом виде, начиная со старшего разряда. дайте ответ...
51179
15.05.2020 08:37
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 10 000 включительно. Напишите программу, которая находит сумму элементов...
saba22
13.03.2020 12:48
Даны 2017 монет среди них одна фальшивая , но незнаем легкая она или тяжелая. определить фальшивою монету. за сколько взвешиваний это можно сделать...
Ardashelovna
11.03.2021 00:03
Вдвумерном массиве 4х3 найти количество элементов, больших -5. если таких элементов не оказалось - вывести сообщене таких элементов нет! . элементы ввести с клавиатуры....
marek2
02.09.2021 16:47
Xiaomi Redmi 9A Я случайно увеличил максимальную ширину и меня стало черный экран, потом появился , скажите как выйти с этого Main Menu не удалив данные, я уже пробовал нажимал...
Franker10
21.05.2020 21:12
1. в какой органелле происходит процесс клеточного дыхания? 2. где происходит гликолиз?...
Коцюрбей
21.05.2020 21:12
Решите примеры а) -3-8+12-4+11 б) 4 - 5 + 11 - 9 - 4 в) 9-2-8+4-21 г) -16-7+32-21+17 д) -16+9+27 - 11-8...
ppetrovaa
21.05.2020 21:12
Можете подсказать слова на казахском языке на тему я ученик . буду ....
мик104
21.05.2020 21:12
Написать письмо обращение к сестре....
wwwlavor
21.05.2020 21:12
Із 4кг проса одержують 3кг пшона. скільки кілограмів пшона вийде з 1ц 20кг проса?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a,b,c,d:real;
s:integer;
begin
Write('Введите a b c d: '); Read(a,b,c,d);
if frac(a)=0 then s:=Trunc(a) else s:=0;
if frac(b)=0 then s:=s+Trunc(b);
if frac(c)=0 then s:=s+Trunc(c);
if frac(d)=0 then s:=s+Trunc(d);
Writeln('S=',s)
end.
Пример
Введите a b c d: 2.5 6 -3 -1.75
S=3