В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
serjo1216
serjo1216
08.03.2022 04:26 •  Информатика

Среди заданных целых чисел A,B,C,D есть хотя бы два четных? Напишите программу на pascal ABC

Показать ответ
Ответ:
анна2248
анна2248
13.03.2021 00:13

var

 a, b, c, d, kol: integer;

begin

   write('Введите четыре числа A, B, C и D через пробел: ');

   readln(a, b, c, d);

   if a mod 2 = 0 then inc(kol);

   if b mod 2 = 0 then inc(kol);

   if c mod 2 = 0 then inc(kol);

   if d mod 2 = 0 then inc(kol);

   if kol >= 2 then writeln('Среди введенных чисел есть два или более четных числа')

     else writeln('Среди введенных чисел менее двух четных');

end.

Объяснение:

Другой вариант (покороче):

var

 a, b, c, d: integer;

begin

   write('Введите четыре числа A, B, C и D через пробел: ');

   readln(a, b, c, d);

   if ((a mod 2) + (b mod 2) + (c mod 2) + (d mod 2)) <= 2

       then writeln('Среди введенных чисел есть два или более четных числа')

       else writeln('Среди введенных чисел менее двух четных');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота