В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dolbaeb2k00
dolbaeb2k00
18.03.2022 09:45 •  Информатика

Срешением двух ! . нужно написать программу на паскаль, заранее, ! ) в двумерном массиве 5 x 5, заполненный случайными числами, найти количество положительных элементовдан двумерный массив a[n,n]. сформировать одномерный массив в, состоящий только их элементов главной диагонали.

Показать ответ
Ответ:
lizochkaegorov
lizochkaegorov
07.07.2020 13:14
Var a: array[1..5,1..5] of integer;
pol,i,j:integer;
begin 
randomize;
for i:=1 to 5 do 
 for j:=1 to 5 do  a[i,j]:=random(100)-50;
for i:=1 to 5 do
  for j:=1 to 5 do  if a[i,j]>0 then inc(pol);
write(pol);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота