Stepik 2.1 шаг 3 из 10 Напишите программу, которая в последовательности целых чисел определяет среднее значение чисел, кратных 6 и оканчивающихся на 4.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. В числовом ряду обязательно есть число кратное 6 и оканчивающееся на 4.
Формат входных данных
Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Формат выходных данных
Программа должна вывести среднее значение чисел, кратных 6 и оканчивающихся на 4.
var A:array[1..20] of integer;
i,k,min,n:integer;
begin
min:=1000000000; // прощу прощение за такое )
for i:=1 to 20 do A[i]:=random(9); // заполняем массив
for i:=1 to high(A) do // находим минимальное нечётное, запоминаем его номер
if (A[i] < min) and (A[i] mod 2 <> 0) then begin
n:=i; min:=A[i];
end;
for i:=1 to 20 do write(A[i]:3); // Выводит весь массив
writeln(); // просто перевод на новую строку для красоты
writeln('Minimum: ',min,' Ego nomer: ',n); // выдаём минимальное и его номер
end.