В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
KathrynMay
KathrynMay
21.10.2022 13:45 •  Информатика

Строки в стиле С •Написать программу, которая вводит символьный массив из 15-ти или
меньшего числа элементов и находит в нем символ с наименьшим ASCII-кодом

Показать ответ
Ответ:
Hamidylla
Hamidylla
31.01.2022 01:00

#include <stdio.h>

#include <windows.h>

#include <string.h>

#define _MAX_STRING_SIZE_ 15

int main()

{  

   SetConsoleCP(65001);

   

   char str [_MAX_STRING_SIZE_];

   scanf("%s", &str);

   int min = (int)str[0];

   for(int i = 0; i < strlen(str); i++)

       if((int)str[i] < min)

           min = (int)str[i];

   printf("%d", min);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота