В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kilaur
kilaur
19.10.2020 12:51 •  Информатика

Структурные операторы в языке pascal: развилка и выбор. 1.даны целые цисла m и n. если числа не равны, то заменить каждое из них одним и тем же числом, равным большему из исходных, а если равны, то заменить числа нулями. 2.составить программу, которая по заданному году и номера месяца m определяет количество дней в этом месяце.

Показать ответ
Ответ:
P4ndainst
P4ndainst
01.10.2020 23:04
Первая прога:
program pr1;
uses crt
var m,n:real;
begin
clrscr;
writeln('insert the numbers');
readln(m, n);
if m <> n then begin
if m > n then begin
n:=m;
end
else begin
m:=n;
writeln(m,n);
end;
end
else begin 
m:=0;
n:=0;
writeln(m,n);
end;
end.

Вторая прога:
program pr2;
ues crt
var y,m,d,k: integer;
begin
clrscr;
writeln('insert the year);
readln(y);
writeln('insert the month');
readln(m);
if m > 12 then begin
writeln('error');
end;
if m mod 2 <> 0  then begin
d:= 31;
end;
if m=2 then begin
d:= 28;
end;
if m mod 2 = 0 then begin
d:=30;
end;
writeln('the number of the days in your month:');
writeln(d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота