Сумма чисел - 4 / используя цикл for/ необходимо написать программу, которая вычислит сумму 1 + 1 / 3 + 1 / (3 * 3) + 1 / (3 * 3 * + 1 / ( делить 3 в степени n) вводится натуральное число n (1≤n≤105). программа должна вывести результат вычисления одним вещественным числом с точностью до шести
знаков после запятой. 5 1.497942
n=10;
m=10;
var
a: array[1..n,1..m] of integer;
b: array[1..n] of integer;
i,j,k: integer;
begin;
k:=0;
writeln ('Двумерный массив:');
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(100)-50;
write (a[i,j]:4);
if (a[i,j]<0) and (abs(a[i,j] mod 2)=1)
then k:=k+1;
end;
writeln;
b[i]:=k;
k:=0;
end;
writeln;
writeln ('Сформирован одномерный массив:');
for i:=1 to n do
write (b[i]:3);
end.
Результат:
Двумерный массив:
19 30 -49 -10 -10 -14 -25 -19 -16 -11
-18 18 1 18 32 21 22 -33 45 45
-50 -26 -24 -47 8 39 14 34 45 -21
-33 5 -26 3 -38 0 -40 31 -42 11
-32 -25 -47 2 -24 34 -48 -27 18 8
12 42 -49 7 23 -5 3 48 32 1
22 -9 -14 -46 -28 26 -6 48 5 -19
11 40 -42 -17 27 25 -29 23 26 24
36 -9 -34 -14 17 -26 3 16 29 17
47 -39 49 7 39 26 39 48 -21 -1
Сформирован одномерный массив:
4 1 2 1 3 2 2 2 1 3