Сумма, делящаяся на три Необходимо найти самый большой непрерывный фрагмент в массиве a1,a2...aN, сумма элементов которого делится на 3. Входные данные В первой строке входного файла содержится число N≤100000. Во второй строке входного файла следуют N чисел, по модулю не превосходящих 109 — элементы массива. Выходные данные Выведите два числа — индексы начала и конца фрагмента. Если таких фрагментов несколько, то выведите фрагмент с минимальным индексом начала. Если ответа не существует, то выведите единственное число −1. Примеры Ввод Вывод 4 1 2 3 4 1 3 5 1 2 3 4 5 1 5 Решите на c++
Web-страницы или гипертекстовые документы (html-документы) - это текстовые файлы, размеченные тегами (tags) с языка HTML (HyperText Markup Language). HTML не является языком программирования, он является языком разметки или средством форматирования гипертекста. Для разметки документа используются теги. Теги заключаются в угловые скобки. В основном теги являются парными, т.е. существуют открывающий и закрывающий теги.
Язык разметки HTML позволяет форматировать текст веб страницы, размещать на ней графические объекты, рисунки, вставлять звукозапись и различные мультимедийные элементы, а так же скрипты (JavaScript, VBScript), создавать гипертекстовые ссылки.
Веб-страница начинается и заканчивается парными тегами <html> и </html>. Между этими тегами размещаются парные теги <head>, </head> (голова веб-страницы), между которыми размещаются парные теги <title></title> для заголовка web-страницы, а также вводятся различные метатеги для ключевых слов, описания содержания страницы и т.д.
Затем следуют теги <body>, </body> (тело веб-страницы), между этими тегами размещается содержание или контент страницы.
Вот самый что не на есть стандартный шаблон страницы:
<html>
<head>
<!-- Тут подключаются различные стили, скрипты, а так же указывается краткая информация о странице в виде краткого описания и ключевых слов -->
</head>
<body>
<!-- Тело страницы, тут располагается основной контент -->
</body>
</html>
Это всего лишь основа, на самом деле тегов в разметке очень много, например, есть еще теги <footer>, <sidebar>, <header> и т.д. Я даже не начал говорить о таких тегах как <div>, <ul> и т.п, много!
HTML - позволяет создавать только статичные страницы, т.е вся информация уже будет находиться на определенном .html-файле. Это конечно не плохо, если проект(сайт) будет не большим по размаху, но если он будет содержать 100-1000, а то и более страниц информации, то тут волей не волей уже задумаешься. Поскольку страницы статичные и если захотелось изменить дизайн сайта целиком, то придется редактировать КАЖДУЮ страницу! Это просто огромный, непосильный труд. Поэтому нам на идут языки веб-программирования такие, как PHP, Python и им подобные. Наиболее распространенный - это PHP(Personal HyperText Processor), распространен, потому что с ним легоко работать с БД(делать выборку, удалять, обновлять ну т.п). А в основном данные не статичных страниц хранятся в Базе Данных, это очень удобно и занимает меньше места. С языком ПХП можно просто создать один единый шаблон и просто использовать его, так не придется менять 1000 страниц, достаточно поменять одну единственную.
Это все кратко о создании Веб-страниц, не вдаваясь в детали. Надеюсь кратко и при этом понятно, удачи!:)
using namespace std;
double val, p;
//вводимые параметры значения функции и степень полинома
//x - значение функции
//res - значение, которое изменяется в процессе рекурсии по схеме Горнера
//s - рассматриваемая текущая степень x
double rec(double x, double res, double s)
{
if (s == 0.0)
return res;
return rec(x, x * res + s - 1, s - 1);
}
int main(){
cin >> val >> p;
//старший коэффициент в схеме Горнера сначала сносится вниз,
//поэтому его передаем в качестве начального параметра для результата
cout << fixed << rec(val, p, p) << endl;
return 0;
}