Св паскале! написать решение для программы паскаль. ) имеется массив а из n произвольных чисел (а( среди которых есть положительные, отрицательные и равные нулю. используя оператор цикла, составить программу, выполняющую : найти номера первых двух рядом стоящих одинаковых элементов в массиве. например, если а={2,6,4,4,2,5,5,4}, результат: 3 и 4.
uses crt;
type
arr = array[0..1000] of shortint;
var
ar,b,i:word;
a:arr;
begin
randomize;
for ar:=0 to 999 do
a[ar]:= random(18)-9;
b:=10;
i:=0;
repeat b:=a[i]; i:=i+1; until(b = a[i]) or (i = 999);
if i = 999 then writeln('Повторяющихся чисел нет!') else writeln(i,' ',i+1) ;
end.