Тема: Анализ программы, содержащей циклы и ветвления. Задание 20
1) Укажите минимальное натуральное число, при вводе которого этот алгоритм напечатает сначала 7, а потом – 12.
var x, a, b: longint;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
if x mod 2 > 0 then
a := a + x mod 12
else
b := b * (x mod 12);
x := x div 12;
end;
writeln(a); write(b);
end.
2) Укажите минимальное натуральное число, при вводе которого этот алгоритм напечатает число 11.
var x, a, b, d: longint;
begin
readln(x);
a := 0; b := 10;
while x > 0 do begin
d := x mod 7;
if d > a then a := d;
if d < b then b := d;
x := x div 7
end;
writeln(a+b)
end.
3) Укажите минимальное двузначное натуральное число, при вводе которого этот алгоритм напечатает число 8.
var x, a, b, d: longint;
begin
readln(x);
a := 0; b := 10;
while x > 0 do begin
d := x mod 6;
if d > a then a := d;
if d < b then b := d;
x := x div 6
end;
writeln(a+b)
end.
4) Получив на вход натуральное число x, этот алгоритм печатает два числа: a и b. Сколько существует таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 12?
var x, a, b: longint;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
a := a+1;
if (x mod 14) <> 0 then
b := b*(x mod 14);
x := x div 14;
end;
writeln(a); write(b);
end.
5. Получив на вход натуральное число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее трёхзначное натуральное число, при вводе которого алгоритм печатает сначала 4, а потом тоже - 4.
var x, a, b: longint;
begin
readln(x);
a := 0; b := 0;
while x > 0 do begin
if x mod 2 = 0 then
a := a + x mod 5
else
b := b + x mod 5;
x := x div 5;
end;
writeln(a); write(b);
end.
6. Получив на вход натуральное число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее четырёхзначное натуральное число, при вводе которого алгоритм печатает сначала 4, а потом тоже - 4.
var x, a, b: longint;
begin
readln(x);
a := 0; b := 0;
while x > 0 do begin
if x mod 2 > 0 then
a := a + x mod 9
else
b := b + x mod 9;
x := x div 9;
end;
writeln(a); write(b);
end.
7. Получив на вход натуральное число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее натуральное число, при вводе которого алгоритм печатает сначала 3, а потом 12.
var x, a, b: longint;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
if x mod 2 > 0 then
a := a + x mod 13
else
b := b * (x mod 13);
x := x div 13;
end;
writeln(a); write(b);
end.
Объяснение:
Начну с того, что в программах на языке C# используются управляемые и неуправляемые объекты. Управляемые объекты без проблем удаляются сборщиком мусора. В то время, как неуправляемые объекты необходимо освобождать вручную.
В C# есть два освобождения ресурсов: через деструктор или через метод Dispose, который определен в интерфейсе IDisposable.
Деструктор вызывается автоматически во время удаления объекта сборщиком мусора, но момент его вызова определить невозможно, так как сборщик мусора запускается только при недостатке памяти. Таким образом, объекты могут находиться в памяти вплоть до завершения программы.
Метод Dispose вызывается программистом (использующим этот класс), когда объект больше не нужен. При этом подходе происходит немедленное освобождение ресурсов. Минус подхода - программист может попросту забыть вызвать метод Dispose.
В вашем коде приведен беспроигрышный вариант: в методе f происходит освобождение управляемых и неуправляемых ресурсов.
Код прокомментировал ниже. Параметр dd необходим, чтобы не освобождать управляемые ресурсы при вызове деструктора, так на момент его вызова мы не можем быть уверенными в их состоянии, что они до сих пор находятся в памяти.
namespace ConsoleApp17
{
public class A : IDisposable // Объявление класса, реализующего интерфейс IDisposable
{
private bool disposed = false; // Объект уничтожен?
public void Dispose()
{
GC.SuppressFinalize(this); // Запрещаем сборщику мусора вызывать деструктор при удалении объекта
f(true); // Вызываем метод освобождения неуправляемых и управляемых ресурсов
Console.WriteLine(" Call dispose ");
}
private void f(bool dd)
{
if (!this.disposed) // Если объект не уничтожен, то уничтожаем
{
if (dd) // Если true, то освобождаем также управляемые ресурсы
Console.WriteLine("Dispose managed resourse. GC.collect()");
// Освобождаем неуправляемые ресурсы
Console.WriteLine("Clean up unmanaged resources");
}
disposed = true; // Помечаем, что объект уничтожен
}
~A() // Деструктор
{
f(false); // Вызываем метод освобождения неуправляемых ресурсов
Console.WriteLine("Call destruktor");
}
}
class Program
{
static void Main(string[] args)
{
A ob = new A(); // Создание объекта
ob.Dispose(); // Уничтожение объекта
}
}
}
Не совсем верно, но очень близко.
uses crt;
const nmax=100;
var a:array[1..nmax] of integer;
n,i,j,k:byte;
begin
clrscr;
repeat
write('Размер массива до ',nmax,' n=');
readln(n);
until n in [1..nmax];
writeln('Введите элементы массива:');
for i:=1 to n do
begin
write('a[',i,']=');
readln(a[i]);
end;
clrscr;
writeln('Массив:');
for i:=1 to n do
write(a[i]:4);
writeln;
writeln;
k:=0;
for i:=1 to n-1 do
for j:=i+1 to n do
if a[j]=a[i] then k:=k+1;
if k=1 then write('В массиве только 2 одинаковых элемента')
else write('В массиве не 2 одинаковых элемента');
readln
end.
Объяснение: