В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
DAVIDUIOP
DAVIDUIOP
20.12.2021 14:58 •  Информатика

Тема. двумерные массивы. дан массив из n x m элементов. найти наибольший элемент массива. паскаль

Показать ответ
Ответ:
upsbeats
upsbeats
01.10.2022 07:39

ответ: Программа рабочая, проверена.

Program zadacha;

var  

 a: array [1..50] of integer; // размерность массива = 50

 i,k: integer;

begin

begin

 for i:=1 to 50 do

   a[i] := Random(100); // числа от 0 до 100 будут присутствовать в массиве

 writeln('Заполненный массив: ');

 for i:=1 to 50 do

   write(a[i],' '); end; // выводим массив на экран до проверки

writeln; //новая строка

writeln('Введите значение числа K: '); readln(k);

writeln('Элементы массива, кратные K:');

for i:=1 to 50 do

if (a[i] mod k = 0) then write(a[i],' ');  

end.

Объяснение:

i - порядковый номер элемента

a - сам массив

k - вводимое число

В остальном оставила комментарии.

Размерность массива и его диапазон указан в программе числами, т.к. в задаче не было вопроса о вводе элементов или вводе размерности.


ИНФОРМАТИКА 9 КЛАСС Работа с системой программирования на языке Паскаль Напишите программу для реа
0,0(0 оценок)
Ответ:
Верче02
Верче02
14.08.2021 10:31
Var
  h1,h2:integer;
  n1,n2:string;
begin
  Write('Введите имя первой девочки: '); Readln(n1);
  Write('Введите рост первой девочки: '); Readln(h1);
  Write('Введите имя второй девочки: '); Readln(n2);
  Write('Введите рост второй девочки: '); Readln(h2);
  if h1>h2 then Writeln(n1,' выше, чем ',n2)
  else if h2>h1 then Writeln(n2,' выше, чем ',n1)
  else Writeln(n1,' и ',n2,' одного роста')
end.

Тестовое решение:
Введите имя первой девочки: Наташа
Введите рост первой девочки: 163
Введите имя второй девочки: Даша
Введите рост второй девочки: 167
Даша выше, чем Наташа

Блок-схема дана во вложении. Блоки ввода вывода упрощены в связи с невозможностью (и ненужностью) точно отобразить вид ввода и вывода.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота