Тема называется ''нахождение экстремальных элементов в одномерных массивах''
звучит так - ''составить программу нахождения заданного экстремального элемента или его порядкового номера при заданном одномерном массиве а из n элементов (или массивах а и с по n элементов в каждом)
не забывать, сформулированы для i=1,. делайте
корректировку согласно принятой в языке индексации при
написании программ.
так звучит для всех и идут индивидуальные, они-то мне и нужны-''определить наименьшее из значений ((2 / а i ) +(a i ^2))''
язык программирования python буду за пояснение, что да как, и признательна за написание кода : з
var
n,i,k,sum,g:integer;
begin
readln(n);
g:=n;
while n<>0 do begin
g:= g div 10;
k +=1;
end;
for i:=1 to k do begin
g:= n mod 10;
sum:= sum + g;
n:=n div 10;
end;
if sum> 10 then
writeln('верно')
else
('неверно');
end.
2.
var
n,i,k,p,h,g:integer;
begin
readln(n);
g:=n;
while n<>0 do begin
g:= g div 10;
k +=1;
end;
p:=n mod 10;
n:=n div 10;
for i:=1 to k-1do begin
g:= n mod 10;
if g = p then
h += 1;
n:=n div 10;
end;
writeln(h);
end.
3.
const
n=10;
var
a:array[1..n]of integer;
i,sum:integer;
begin
a[n]:=0;
for i:=1 to 9 do
readln(a[i]);
for i:=1 to n do
sum:=sum+a[i];
writeln(sum);
end.
4.
var
n:integer;
begin
readln(n);
while n<>0 do begin
n:=n div 10;
k += 1;
end;
if k = 4 then
writeln('число четырехзначное')
else
writeln('число не четырехзначное');
end.
5.
var
a:array[1..10]of integer;
i:byte;
begin
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do begin
if a[i] = 2 then
writeln('да есть');
break;
end;
end.
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
unit MatInt;
interface
type
Matrix=array[,] of integer;
function MatCreate(m,n:integer):Matrix;
procedure MatPrint(a:Matrix;w:integer);
procedure MatMax(a:Matrix;var x,imax,jmax:integer);
implementation
function MatCreate(m,n:integer):Matrix;
// создает матрицу и инициализирует её нулями
begin
SetLength(Result,m,n);
end;
procedure MatPrint(a:Matrix;w:integer);
// выводит матрицу, отводя w позиций под элемент
begin
var n:=Length(a,1)-1;
for var i:=0 to Length(a,0)-1 do begin
for var j:=0 to n do Write(a[i,j]:w);
Writeln
end
end;
procedure MatMax(a:Matrix;var x,imax,jmax:integer);
// возвращает значение максимального элемента и его координаты
begin
imax:=0; jmax:=0;
var n:=Length(a,1)-1;
for var i:=0 to Length(a,0)-1 do
for var j:=0 to n do
if a[i,j]>a[imax,jmax] then (imax,jmax):=(i,j);
Inc(imax); Inc(jmax); x:=a[imax-1,jmax-1]
end;
end.
2. Компилируем файл, получая библиотеку MatInt.pcu
3. Пишем основную программу:
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
uses
MatInt;
begin
var a:=MatCreate(5,8);
var n:=Length(a,1)-1;
for var i:=0 to Length(a,0)-1 do
for var j:=0 to n do a[i,j]:=Random(-50,50);
MatPrint(a,4);
var irow,jcol,max:integer;
MatMax(a,max,irow,jcol);
Writeln('Максимальный А[',irow,',',jcol,']=',max)
end.
Тестовое решение
11 -16 11 16 23 -4 -17 -34
-12 -5 20 9 16 47 43 17
-46 -26 47 -40 12 -31 -25 13
-7 39 -20 26 11 -19 32 -15
45 -10 -28 31 -46 -29 -29 -22
Максимальный А[2,6]=47