В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Aigerimmmmmmm
Aigerimmmmmmm
30.01.2023 07:20 •  Информатика

Тема: одномерные массивы, написать программу использую rite, riteln ; все элементы кратные трем делятся на три, остальные умножаются на 3.

Показать ответ
Ответ:
MikhailMaksimovich
MikhailMaksimovich
02.07.2020 19:16
Const N=...;//указываешь количество элементов массива
var a:array [1..N] of integer;
i:integer;
begin
for i:=1 to N do 
readln(a[i]);
for i:=1 to N do begin
 if a[i] mod 3 =0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;
writeln(a[i]);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота