В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Солі
Солі
10.12.2022 12:07 •  Информатика

Тема Python: 1)Выполните задания по порядку:
1. В третьей строке оформите вывод переменной y с форматного вывода, с количеством знаков в дробной части по умолчанию
2. В четвертой строке оформите вывод переменной y, чтобы выводилось все число в 10 позициях, при этом на дробную часть отводилось 4 знака
3. В пятой строке оформите вывод переменной y, чтобы число выводилось в научном формате с тремя цифрами в дробной части
y = 1/2 + 1/3 + 1/4 + 1/5
2-print(y)
3-print()
4-print()
5-print()
2)Напишите программу, которая вычисляет квадратный корень введенного с клавиатуры числа, с точностью до трех знаков после запятой.
На вход подается вещественное число.
Входные данные:25
Выходные данные:5.000
3)Дано положительное вещественное число X. Выведите его дробную часть:
Входные данные:5.5
Выходные данные:0.5

Показать ответ
Ответ:
александр383
александр383
21.04.2022 12:50

#include <iostream>

int main()

{

   setlocale(LC_ALL, "rus");

   double r1, r2, r;

   int connection;

   std::cout << "r1=";

   std::cin >> r1;

   std::cout << "r2=";

   std::cin >> r2;

   do {

       std::cout << "Выберите тип подключения (1-последовательно, 2 параллельно): ";

       std::cin >> connection;

   } while (connection != 1 && connection != 2);

   if (connection == 1) r = r1 + r2;

   else r = r1*r2/(r1 + r2);

   std::cout << "Результат r=" << r;

}

0,0(0 оценок)
Ответ:
aminatikhonova12
aminatikhonova12
21.04.2022 12:50

1) Канал связи - система технических средств и среда распространения сигналов для односторонней передачи данных от отправителя к получателю. В случае использования проводной линии связи, средой распространения сигнала может являться оптическое волокно или витая пара. Канал связи является составной частью канала передачи данных.

2) Локальная компьютерная сеть - компьютерная сеть, покрывающая обычно относительно небольшую территорию или небольшую группу зданий. Термин LAN также используется в киберспорте и означает, что игроки находятся в одном помещении и связаны локальной сетью, а не играют из дома через интернет.

В обобщенной структуре ЛКС выделяются совокупность абонентских систем (АС), серверов и коммуникационная подсеть (КП). Основными компонентами ЛКС являются кабели с оконечным приемопередающим оборудованием, рабочие станции (РС), серверы, сетевые адаптеры, модемы, концентраторы, коммутаторы, маршрутизаторы, мосты

3) Глобальная компьютерная сеть - Компьютерная сеть, охватывающая большие территории и включающая большое число узлов, возможно находящиеся в различных городах и странах.

4) Интернет - Всемирная система объединённых компьютерных сетей для хранения и передачи информации.

5) Глобальная компьютерная сеть (КС) представляет собой сеть обмена и распределенной обработки информации, образуемая множеством взаимосвязанных РС сети и средствами связи. Рабочая станция (РС) сети или абонентская система (АС) - система оборудования конечного пользователя сети, включающая сетевой компьютер вместе с периферийными средствами ввода-вывода и программным обеспечением (ПО), средства связи с коммуникационной подсетью компьютерной сети.

6) ADSL (Asymmetric Digital Subscriber Line). Это новая модемная технология, превращающая стандартные абонентские телефонные аналоговые линии в линии высокоскоростного доступа.

7) Скорость передачи информации вычисляется по формуле: V = I/t, где V — скорость передачи, I — объем передаваемой информации, t — время, за которое она была передана. Пропускная канала — максимальное количество переданной или полученной по этому каналу информации за единицу времени.

p.s можно лучший ответ :)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота