В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
striyskiy1
striyskiy1
13.09.2022 22:31 •  Информатика

Тема: сдвиг информатика (напишите программу)дано 4 числаa b c d сдвиньте на d c b a1 2 3 4 cдвиньте на 4 3 2 1! !

Показать ответ
Ответ:
sonyacherepanova
sonyacherepanova
24.04.2023 01:01
По выполняемым функциям и возможности применения информационные технологии делят на используемые:1) в автономных компьютерах (ПЭВМ) и в локальных рабочих станциях (АРМ) в составе сетевых автоматизированных информационных систем (АИС) реального времени;2) в объектно-ориентированных, распределённых, корпоративных и иных локальных и сетевых информационно-поисковых, гипертекстовых и мультимедийных системах;3) в системах с искусственным интеллектом;4) в интегрированных АИС;5) в геоинформационных, глобальных и других системах.
0,0(0 оценок)
Ответ:
Alinochka1mimimi
Alinochka1mimimi
15.06.2022 13:08
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота