В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kudar2
kudar2
16.01.2020 14:01 •  Информатика

Тест
b19 - обработка массивов
в программе используется одномерный целочисленный массив ас индексами от 0 де
9. значения элементов равны 1, 5, 3, 7, 9, 8, 1, 12, 6, 14
соответственно, т.е. a [0] =1, a[ 1] =5ит.д. определите значение переменной ѕ
после выполнения следующего фрагмента этой программы:
s : = 0;
n: = 10;
for i: =1 to n-2 do begin
s : = s + a[i] - a[i+1];
end;
вредите правильный ответ​

Показать ответ
Ответ:
ghigalskiidani
ghigalskiidani
04.02.2020 19:21

Вот ссылка на готовую прогу → https://yadi.sk/d/pRyX2bUGMIdWsw

Объяснение:

Это было сделана на среде программирования Delphi 7 в консольном режиме.

P.S: Код программы↓

var

i,s,n: longint;  // объявляем переменные

begin  

SetConsoleCP(1251);  // для вывода в консоль русские символы

SetConsoleOutputCP(1251);  // для вывода в консоль русские символы

write('Здравствуйте! Введите любое число: ');  //вывод сообщения

readln(n);  // запишем то, что написал пользователь

s:=0;  // присвоим для начало 0

for i:=2 to n do  

    if i mod 2 = 0 then s:=s+i;

writeln('Ваше число: ', s);  //выводим S

readln;

end.

Я плохо объясняю, но думаю ты понял.

0,0(0 оценок)
Ответ:
angelina453
angelina453
21.02.2021 15:16

Объяснение:

экран монитора без изображения дает зеркальное отражение (видны окружающин предметы), частично зеркальное у книг с блестящей обложкой (видны окна и другие источники света) , у карточек оплаты за интернет, если есть спутниковая антенна, то она зеркало для телевизионных волн, покрытые никелем ручки у звуковой системы и т. д. Диффузное (в самых разных направлениях) у бумаги, карандаша, бутылочки с корректором текстов, салфеток и скатерти, пластмассы корпуса монитора и краски корпуса самого компьютера и т. д. Сходите на кухню - там примеров еще больше. Имейте ввиду что цветная поверхность дисков представляет собой дифракционное отражение с интерференционной картиной. Короче - осторожнее с радужными цветами (например, мыльным пузырем)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота