В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
DKNRMLLY
DKNRMLLY
14.03.2021 21:45 •  Информатика

Только для ! составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. на экран должен быть выведен результат выполнения соответствующего арифметического действия. для ввода знака использовать переменную типа char.

Показать ответ
Ответ:
Георгий11712
Георгий11712
03.10.2020 06:19
Var 
s: char; 
a, b: real;
begin 
Write('Введите два числа '); 
Readln(a, b); 
Write('Введите действие (+, -, *, /) - '); 
Readln(s); 
case s of    
'+': writeln(a, ' + ', b, ' = ', a + b);   
'-': writeln(a, ' - ', b, ' = ', a - b);   
'*': writeln(a, ' * ', b, ' = ', a * b);   
'/': if (b=0) then writeln('На ноль делить нехорошо - бесконечность получится') else writeln(a, ' / ', b, ' = ', a / b);
End;
end.
0,0(0 оценок)
Ответ:
Natasatana
Natasatana
03.10.2020 06:19
Var  Ch : Char;
  a,b : Integer;
Begin
  Readln(a,b);
  Readln(Ch);
  Case Ch of
   '+' : Writeln(a+b);
   '-' : Writeln(a-b);
   '*' : Writeln(a*b);
   '/' : Writeln(a/b);
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота