Требовалось написать программу, которая определяет, лежит ли точка А(х,у) внутри некоторого кольца («внутри» понимается в строгом смысле, т.е. случай, когда точка А лежит на границе кольца, недопустим). Центр кольца находится в начале координат. Для кольца заданы внутренний и внешний радиусы r1, r2; известно, что r1 отлично от r2, но неизвестно, r1 > r2 или r2 > r1. В том случае, когда точка А лежит внутри кольца, программа должна выводить соответствующее сообщение, в противном случае никакой выходной информации не выдается. Программист сделал в программе ошибки.
var x, у, rl,r2:real;
h: real;
begin
readln (x, у, rl, r2);
h := sqrt (x*x + y*y);
if (h < rl) AND (h > r2) then
writeln ('точка А лежит внутри кольца');
end.
Последовательно выполните задания:
1. Приведите пример таких чисел х и у, при которых программа неверно решает поставленную задачу.
2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими поэтому можно указать любой доработки исходной программы).
3. Укажите, как можно доработать программу, чтобы она не содержала логических операций AND или OR.
Примечание: для обозначения расстояния от точки А до начала координат используется вс переменная h.
const
n=7;
var
p,d:array[2..n] of integer;
a:array[1..n] of string:=('426','62','84','4','2','8','24');
prim115:boolean;
procedure Perm(n:integer);
var
t:string;
k,q:integer;
label index,iter,trans;
begin
if prim115 then begin
prim115:=False;
for k:=2 to n do begin p[k]:=0; d[k]:=1 end
end;
k:=0;
index:
q:=p[n]+d[n]; p[n]:=q;
if q=n then begin d[n]:=-1; goto iter end;
if q<>0 then goto trans;
d[n]:=1; k:=k+1;
iter:
if n>2 then begin n:=n-1; goto index end;
q:=1; prim115:=true;
trans:
q:=q+k; t:=a[q]; a[q]:=a[q+1]; a[q+1]:=t
end;
var
s,maxs:string;
i,m:integer;
pal:boolean;
begin
prim115:=true; maxs:='';
repeat
s:='';
for i:=1 to n do s:=s+a[i];
m:=Length(s); pal:=True;
for i:=1 to m div 2 do
if s[i]<>s[m-i+1] then begin pal:=false; break end;
if pal then
if maxs<s then maxs:=s;
Perm(n);
until prim115;
Writeln(maxs)
end.
Результат выполнения программы:
842624426248
Рассмотрим число 426. Так как мы составляем палиндром, при этом количество чисел в палиндроме чётное, то в нем должна быть обратная запись этого числа - 624. Её мы можем получить из чисел 62 и 4.
Имеем: зеркальные числа 426 и 624
Остались числа 84, 2, 8, 24. Из них мы можем составить два зеркальных числа - 842 и 248. Осталось составить палиндром. Так как надо создать максимально возможный палиндром, то число 842 должно быть вначале, а после - число 624.
ответ:
842624426248