Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). Программист торопился и написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится пять ошибок:
к := 1;
f := 0;
while k f:=f * k;
к:=к + 1
Найдите ошибки. Допишите необходимые операторы и выполните программу на компьютере.
Пример входных данных
Пример входных данных Пример выходных данных
Введите n> 5 5!=120
Введите n> 6 6!=720
#include <iostream>
using namespace std;
int main()
{
double x, y, z; // объявления переменных для длин сторон
bool b; // логическая переменная, true - построить можно, false - построить нельзя
setlocale(LC_ALL, "Russian");
cout << "Введите длины сторон треугольника: ";
cin >> x >> y >> z; // ввод длин сторон
b = false; // начальное значение для b
if (x >= y && x >= z) // если x самая длинная сторона треугольника
b = x < y + z; // проверяем, что длинная сторона меньше суммы двух других сторон, результат сохраняем в b
else if (y >= x && y >= z) // если y самая длинная сторона треугольника
b = y < x + z; // проверка та же
else if (z >= x && z >= y) // если z самая длинная сторона треугольника
b = z < x + y; // проверка та же
if (b) // смотрим b и выводим соответствующее сообщение
cout << "\nТреугольник построить можно\n";
else
cout << "\nТреугольник построить нельзя\n";
}
#include <iostream>
#include <string.h>
using namespace std;
#define MAX 128
char str[MAX], alf[MAX];
int main()
{
puts("Input name: ");
gets(str);
strlwr(str);
for(int i = 0; i <= 'z' - 'a'; i++)
alf[i] = 'a' + i;
for(int i = 0; i < strlen(str); i++)
if ((str[i] >= 'a') && (str[i] <= 'z'))
alf[str[i] - 'a'] = '0';
cout << "Letters that are not in the name: ";
for(int i = 0; i <= 'z' - 'a'; i++)
if (alf[i] != '0')
cout << alf[i] << " ";
return 0;
}