В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Михалкова
Михалкова
19.12.2021 21:57 •  Информатика

Требуется написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – вещественные числа) и определяет принадлежность точки

заштрихованной области, включая ее границы.

При составлении таблицы контрольных примеров отдельно пропишите

проверку попадания точки в области, обозначенные на рисунке заглавными

латинскими буквами.


Требуется написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – веще

Показать ответ
Ответ:
leyla623
leyla623
16.06.2021 20:20

int main()

{    

float x;

float y;

std::cin >> x;

std::cin >> y;

if ((x * x + y * y <= 1) or (x<=1 and x>=0 and y<=1 and y>=0))  

{

 std::cout << "YES";

}

else

{

 std::cout << "NO";

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота