Требуется написать программу, которая выводит скорость и время движения автомобиля и выводит на экран расстояние, которое он проехал. Определите входные данные и результат этого алгоритма. К какому типу относятся входные данные:
Выберите элемент.
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Выберите элемент.
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:
алгоритм
Запишите формулу, которая связывает исходные данные и результат:
const n=30;
var k:array[1..n] of integer; i,t,p:integer;
begin
randomize;
for i:=1 to n do begin
k[i]:=random(100);
if (k[i]>0) then p:=p+1;
if (i=3) and (k[3]>0) then t:=k[3];
end;
if (p<3) then write('В массиве меньше трех положительных элементов') else writeln('Третий элемент массива равен ', t);
end.
Отрицательного значения в массиве не будет, напиши формулу к массиву k[i]:=твоя формула. Формула должна быть такой, чтобы попадались и отрицательные элементы, а так, программа рабочая
Итак, всего есть 5 вариантов мороженого:
пломбир с орехами;
пломбир с бананами;
пломбир с черникой;
шоколадное с черникой;
шоколадное с клубникой
Начиная понемногу убирать варианты мы прийдем к правильному ответу:
1) По условию Ирене нравится мороженое с фруктами, следовательно она не любит орехи.
2) Скорее всего, Ирене не нравится черника, т.к. черника повторяется 2 раза в двух типах разного мороженого и следовательно одно бы из них подошло, но это противоречело-бы условию.
3) Т.к. по условию её не нравится ни орехи ни черника можно сделать вывод, что скорее всего ей нравится пломбир, т.к. в одном мороженом её не нравилось само мороженое, а в другом наполнитель, и отсюда пломбир нам подходит.
4) Из пункта 2) и 3) следует,что мороженое, которое не удовлетворяет Ирену ни по самому мороженому, ни по наполнителю - шоколадное с черникой
5) Из пункта 4) можно сказать, что Ирене не нравится шоколадное мороженое.
6) Бананая начинка не подходит т.к. её нравится пломбир и в условии сказано, что её понравилось либо само мороженое, либо начинка.
Отсюда можно сделать вывод, что единственное мороженое, которое подходит по характеристика будет пломбир с клубникой
ответ: Пломбир с клубникой