В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gregsorvenkov
gregsorvenkov
29.07.2022 00:42 •  Информатика

Требуется написать программу на c++ даны натуральные числа n и m (0≤m≥9). найти сумму первых m цифр числа n. если цифр в n меньше, чем m, то считать недостающие цифры равными 0.

Показать ответ
Ответ:
bubininaaas5
bubininaaas5
20.08.2020 12:29
#include <iostream>
using namespace std;

int main()
{
    int n, m, n1;
    int s=0;
    int k=0;
    cout << "n = ", cin >> n, cout << "\n";
    cout << "m = ", cin >> m, cout << "\n";
    n1 = n;
    while (n1 > 0){
    s += n1 % 10;
    n1 = n1 / 10;
    k++;
    }
    n1 = n;
    for (int i=1; i<=k-m; i++) {
    s -= n1 % 10;
    n1 = n1 / 10;
    }
    cout << "s = " << s << "\n";
    return 0;
}

Пример:
n = 34568
m = 4
s = 18
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота