Требуется написать программу на любом ЯП f(x) sin(0.5x)-x^2+1 [0; Пи] h= Пи/5 n1=2 n2=3 Точки x1, x2, x3 для вычисления значений интерполяционных многочленов 0.81 1.44 2.81
Гиперссылка может быть добавлена к любому элементу гипертекстового документа и обычно выделяется графически. В HTML-документах текстовые ссылки по умолчанию выделяются синим цветом, при наведении на них курсором мыши в окне браузера изменяются, например, меняют цвет или выделяются подчеркиванием. При навигации в браузере с клавиатуры текстовые и графические ссылки выделяются прямоугольной пунктирной рамкой. Посещенная ранее ссылка обычно выделяется цветом, отличным от цвета не посещённой ссылки.
1)var a:array [1..10] of integer; i,sum:integer;begin randomize; sum:=0; for i:=1 to 10 do begin a[i]:=random(100)-50; write (a[i],' '); if a[i] < 0 then sum:=sum+a[i]; end; writeln; writeln ('Summa: ',sum); readln;end. 2)var a:array [1..10] of integer; i,max,index:integer;begin for i:=1 to 10 do begin write ('A[',i,'] = '); readln (a[i]); end; max:=a[1]; index:=1; for i:=2 to 10 do if a[i] > max then begin max:=a[i]; index:=i; end; writeln ('Max: ',max,'.Index: ',index); readln;end. 3)var a:array [1..10] of integer; max,min,i,temp:integer;begin randomize; for i:=1 to 10 do begin a[i]:=random(50); write (a[i],' '); end; writeln; max:=1; min:=1; for i:=2 to 10 do if a[i] > a[max] then max:=i else if a[i] < min then min:=i; writeln ('Max: ',a[max]); writeln ('Min: ',a[min]); temp:=a[min]; a[min]:=a[max]; a[max]:=temp; for i:=1 to 10 do write (a[i],' ');end.Не знаю- правильно ли?
Гиперссылка может быть добавлена к любому элементу гипертекстового документа и обычно выделяется графически. В HTML-документах текстовые ссылки по умолчанию выделяются синим цветом, при наведении на них курсором мыши в окне браузера изменяются, например, меняют цвет или выделяются подчеркиванием. При навигации в браузере с клавиатуры текстовые и графические ссылки выделяются прямоугольной пунктирной рамкой. Посещенная ранее ссылка обычно выделяется цветом, отличным от цвета не посещённой ссылки.
2)var a:array [1..10] of integer; i,max,index:integer;begin for i:=1 to 10 do begin write ('A[',i,'] = '); readln (a[i]); end; max:=a[1]; index:=1; for i:=2 to 10 do if a[i] > max then begin max:=a[i]; index:=i; end; writeln ('Max: ',max,'.Index: ',index); readln;end.
3)var a:array [1..10] of integer; max,min,i,temp:integer;begin randomize; for i:=1 to 10 do begin a[i]:=random(50); write (a[i],' '); end; writeln; max:=1; min:=1; for i:=2 to 10 do if a[i] > a[max] then max:=i else if a[i] < min then min:=i; writeln ('Max: ',a[max]); writeln ('Min: ',a[min]); temp:=a[min]; a[min]:=a[max]; a[max]:=temp; for i:=1 to 10 do write (a[i],' ');end.Не знаю- правильно ли?