В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Aferistik
Aferistik
23.01.2020 04:53 •  Информатика

Требуется отсортировать массив по неубыванию методом "пузырька". в первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива. во второй строке nчисел – элементы массива (целые числа, не превосходящие по модулю 1000). на с++ !

Показать ответ
Ответ:
111dashamm639
111dashamm639
05.07.2020 09:54
A:array[1..1000] of integer;
i, k, z, n, j:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n-1 do
for j:=1 to n-i do
if a[j]>a[j+1] then begin
z:=a[j]; a[j]:=a[j+1]; a[j+1]:=z; end;
for i:=1 to n do
writeln(a[i]);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота