В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Manasyan85140
Manasyan85140
16.05.2021 19:16 •  Информатика

Требуется разработать программу, которая получает с клавиатуры координаты точки на плоскости, и определяет, попадает ли точка в залитую оранжевым область (линии в область не входят). написать программу нужно двумя можно в одной программе ввести данные, а потом двумя получить результат): 1) с применением логических операций 2) с вложенных условных операторов. разрешается также применение функций, арифметических операций. ответ - текст программы в документе ms word.

Показать ответ
Ответ:
ПолинаВозгрина
ПолинаВозгрина
29.05.2020 09:21

Могу подсказать только 1 вариант:

Объяснение:

Module Module1

   Sub Main()

       Dim x As Single

       Dim y As Single

       Console.WriteLine("Введите координаты точки x ")

       x = Console.ReadLine()

       Console.WriteLine("Введите координаты точки y ")

       y = Console.ReadLine()

       If (x <= 4 And y <= 4 And y >= 4 - x) Or (y <= -4 - x And y >= -4 And x >= -4) Then Console.WriteLine("Точка принадлежит области") Else Console.WriteLine("Точка не принадлежит области")

       Console.ReadKey()

   End Sub

End Module

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота