В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tanyalepihina2
tanyalepihina2
04.04.2020 20:13 •  Информатика

Turbo pascal в прямоугольном треугольнике известны 2 катета, их значения вводятся с клавиатуры.вычеслить и вывести на экран sin, cos, tg, ctg. , составить программу.

Показать ответ
Ответ:
Evas2007
Evas2007
21.06.2020 03:51
Var a, b, c: real;
begin
     readln(a, b);
     c := sqrt(sqr(a) + sqr(b));
     writeln('sin a = ', b / c);
     writeln('cos a = ', a / c);
     writeln('tg a = ', b / a);
     writeln('ctg a = ', a / b);
     writeln();
     writeln('sin b = ', a / c);
     writeln('cos b = ', b / c);
     writeln('tg b = ', a / b);
     writeln('ctg b = ', b / a);
end.

Вот так)) Удачи тебе)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота