В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
GanstaRio1
GanstaRio1
17.03.2020 19:49 •  Информатика

У Вас есть фрагмент рулона с автобусными билетами. Написать программу, которая определяет количество счастливых билетов в этом фрагменте. Номера начала и конца фрагмента (два целых шестизначных числа) вводятся с клавиатуры. В случае, если пользователь ввел не шестизначное число выводить на экран сообщение о вводе некорректных данных. на языке си

Показать ответ
Ответ:
alexrukek
alexrukek
04.02.2023 13:54

Первичные документы - это документы, содержащие исходную запись сведений, полученных в процессе исследований, разработок, наблюдений, анализа или других видов человеческой деятельности независимо от ее характера или тематики. Деление документов на первичные и вторичные в значительной степени условно, поскольку один и тот же документ может содержать сведения, относящиеся как к первой, так и второй группе.

Вторичные документы - это документы (отчеты), полученные в результате аналитико-синтетической и логической переработки сведений или данных, содержащихся в первичных документах.

Входные документы: заказ, квитанция о поступлении товара, квитанция о поступлении денежных средств.

К выходным документам относится: отчет о поступлении товара, отчет о продажах, о поступлении денежных средств.

Входные и выходные документы должны, как правило, выполняться на типовых, специализированных и стандартных бланках, что позволяет использовать для их заполнения.

Реквизиты входных и выходных документов наиболее полно удовлетворяют систему расчетов по заработной плате на предприятиях и могут быть использованы без изменений.

При проектировании форм входных и выходных документов возникают две проблемы. Первая связана с проектированием содержания документов, включающего состав реквизитов и показателей, которые будут в него входить.

Используемые в системе формы входных и выходных документов должны быть не только полными, позволяющими охватывать все аспекты задачи, но и экономными, исключающими непроизводительные затраты ручного труда и машинного времени.

Сравнительно легко оценить число входных и выходных документов, которые используются при обработке известного объема данных.

Полный состав и структура записи входных и выходных документов по всему комплексу решаемых задач и видам изданий должен быть определен в ходе технического и рабочего проектирования.

Объяснение:

вот краткое конспектирование пойдет?

0,0(0 оценок)
Ответ:
ZhanelTømmeraas
ZhanelTømmeraas
15.10.2021 04:07

#include<iostream>

#include<ctime>

#include<iomanip>

using namespace std;

void FillArray(int*& arr, int size)

{

for (int i = 0; i < size; i++)

{

 arr[i] = rand() % 100;

}

}

void ShowArray(int*& arr, int size)

{

for (int i = 0; i < size; i++)

{

 cout << arr[i] << "  ";

}

cout << endl << endl;

}

bool CheckArray(int*& arr, int size, int& sum, int& k, int& ki)

{

bool incSeq = 1;

for (int i = 0; i < size; i++)

{

 if (arr[i] % 2 == 0)

 {

  sum += arr[i];

  ki++;

 }

 if (arr[i] > 0)

 {

  k++;

 }

}

for (int i = 1; i < size; i += 2)

{

 if (arr[i] > arr[i + 2])

 {

  incSeq = 0;

  break;

 }

}

return incSeq;

}

int main()

{

srand(time(0));

setlocale(LC_ALL, "ru");

int sum = 0;

int k = 0;

int ki = 0;

int size = 0;

cout << "Укажите размер массива - ";

cin >> size;

int* arr = new int[size];

FillArray(arr, size);

ShowArray(arr, size);

CheckArray(arr, size, sum, k, ki);

if (CheckArray)

{

 cout << "\n\nСредне арифметическое равно  " << fixed << setw(6) << setprecision(2) << (double)(sum / ki);

}

else

{

 cout << "\n\nКол-во чет. эл-ов\n\n - " << k;

}

delete[]arr;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота