В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gaziza4
gaziza4
26.10.2021 23:29 •  Информатика

Уменя есть готовый код паскаля (но я не знаю, по какой причине у меня не получается его увидеть как требуется в (составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. значение n вводится с клавиатуры.) можно переделать код, но без использования uses crt и т.д. сделать нужно с циклом for while и/или repeat. к слову, пользуюсь pascal.abc.net (не знаю, какие значения и где нужно вводить, чтобы получить результат, требуемый в ). program zadacha3; var n, o, p, k, i: integer; a: real; begin repeat write('n = '); readln(n); until (n > 0); i : = 0; k : = 0; p : = 0; o : = 0; repeat write('ввод: '); readln(a); i : = i + 1; if a < 0 then o : = o + 1 else if a > 0 then p : = p + 1 else k : = k + 1; until i = n; writeln('кол-во положительных: ', p); writeln('кол-во отрицательных: ', o); writeln('кол-во нулей: ', k); readln; end.

Показать ответ
Ответ:
dadert1
dadert1
12.07.2020 19:15
Не очень корректно объяснили, но если правильно вас понял:
 Program G;
 Var n, z, m, p: integer;
 Begin 
  z:=0;
  p:=0; 
 m:=0; 
 Writeln('Введите число n. Число 9999 завершает цикл.'); 
 Readln(n); 
 While n<>9999 do 
  Begin   
   If n=0 then inc(z);   
    else if n>0 then inc(p);   
    else inc(m);   
   Writeln('Введите число');   
   Readln(n); 
  End; 
 Writeln('Было введено ', z, ' нулей.'); 
 Writeln('Было введено ', p, ' положительных чисел.'); 
 Writeln('Было введено ', m, ' отрицательных чисел.');  
 Readln;
 End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота