Умоляю, ! напишите программу и запроса даты рождения. использовать нужно переменные для имени (name) и для даты рождения (a, b, c). пример результата работы программы .на экране появляется: тебя зовут иван, ты родился 1.01.2001. напишите на pascal abc
1. Мощность - 64 символа, Объем информации - 30 байт
2. 16 символов
3. 2 и 3 байта соответственно
Объяснение:
1. Формула(Ф1) объема информации , где I - объем в битах, k - количество символов, i - вес одного символа. Подставляем значения: I=40*6=240бит. Т.к. 1байт = 8 бит, то I= 240/8=30 байт.
Мощность алфавита (N) вычисляется по формуле(Ф2) , где i - информационный вес одного символа. Подставляем значения: символа.
2. Объем сообщения 0,5 КБайта, а т.к 1 КБ= байт = бит, то объем сообщения равен бит.
Количество символов в тексте = кол-во символов в строке * кол-во строк * кол-во страниц = символов.
По формуле Ф1 получаем, что , откуда вес одного символа равен бита.
По формуле Ф2 получаем символов
3. Объем первого сообщения бит, второго - бит. Количество символов первого сообщения символов, второго - символов. По формуле Ф1 получаем, что . Подставляем значения: полученные значения в БИТАХ.
т.к. 1 байт = 8 бит, то получаем значения в байтах
#include <stdio.h>
#include <math.h>
#include <locale.h>
main()
{
setlocale(0, "");
int x;
double answer = 0;
printf("Введите значение X: ");
scanf("%d", &x);
if (x >= 0)
{
answer = sqrt(pow(x, 3) + 5);
}
else if (x > -3 && x < 0)
{
answer = 3*pow(x, 4) + 9;
}
printf("ответ: %f", answer);
}
Объяснение:
#include <stdio.h> // Библиотека ввода - вывода
#include <math.h> // Математическая библиотека
#include <locale.h> // Библиотека локализации
main()
{
setlocale(0, ""); // Локализация
int x; // Создание целочисленной переменной x
double answer = 0; // Создание вещественной переменной answer для хранения ответа
printf("Введите значение X: "); // Вывод сообщения в консоль
scanf("%d", &x); // Ввод значения x
if (x >= 0) // Если значение переменной x ≥ 0
{
answer = sqrt(pow(x, 3) + 5); // Вычисляем верхнее выражение
}
else if (x > -3 && x < 0) // Иначе, если значение переменной x > -3 И < 0
{
answer = 3*pow(x, 4) + 9; // Вычисляем нижнее выражение
}
printf("ответ: %f", answer); // Вывод ответа
}