В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
boriskina2006
boriskina2006
16.03.2022 20:35 •  Информатика

Умоляю, ! напишите программу, которая в последовательности натуральных чисел определяет среднее арифметическое всех чисел, кратных 2 и оканчивающихся на 8. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: среднее арифметическое всех чисел, кратных 2 и оканчивающихся на 8.

Показать ответ
Ответ:
narek2006
narek2006
05.10.2020 21:18
Var
  s,n,k:integer;
begin
  Writeln('введите натуральные числа, 0 - окончание ввода');
  k:=0; s:=0;
  repeat
    Read(n);
    if n<>0 then
      if n mod 10 = 8 then begin k:=k+1; s:=s+n end
  until n=0;
  if k>0 then Writeln(s/k:0:4)
  else Writeln(0)
end.
 
Пример
введите натуральные числа, 0 - окончание ввода
34 17 8 32 1424 28 7 0
18.0000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота