В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alexandur96
alexandur96
24.01.2022 20:28 •  Информатика

Уровень A. Напишите программу, которая находит среднее арифметическое всех чисел, записанных в файле в столбик, и выводит результат в другой файл.(ошибка времени исполнения)

var
a, b, c: integer;
d: text;
begin
assign(d,'input.txt');
reset(d);
c:=0;
b:=0;
while not eof do
begin
readln(d,a);
c:= c + a;
b:= b + 1;
end;
close(d);
assign (d,'output.txt');
rewrite(d);
write(d,c/b);
close(d);
end.

Показать ответ
Ответ:
katyavat40owixtk
katyavat40owixtk
05.06.2023 03:45
№ 1 Используя логические операции, запишите высказывания, которые являются истинными при выполнении следующих условий: 1) неверно, что 0 < X ≤ 3 и Y>5; 2) X является max(X,Y); 3) X не является min(X,Y); 4) Z является min(X,Y,Z). № 2 Используя логические операции, запишите высказывания, которые являются истинными при выполнении следующих условий: 1) Y не является max(X,Y,Z) и не является min(X,Y,Z); 2) X,Y,Z равны между собой; 3) каждое из чисел X,Y,Z положительно; 4) каждое из чисел X,Y,Z отрицательно.
0,0(0 оценок)
Ответ:
gjkbyf1984
gjkbyf1984
23.09.2022 04:39

По своему назначению компьютер - это универсальный прибор для работы с информацией. По принципам своего устройства компьютер - это модель человека, работающего с информацией.Персональный компьютер (ПК) — это компьютер, предназначенный для обслуживания одного рабочего места. По своим характеристикам он может отличаться от больших ЭВМ, но функционально выполнять аналогичные операции. По эксплуатации различают настольные (desktop), портативные (laptop и notebook) и карманные (palmtop) модели ПК.Аппаратное обеспечение. Поскольку компьютер предоставляет все три класса информационных методов для работы с данными (аппаратные, программные и естественные), принято говорить о компьютерной системе как о состоящей из аппаратных и программных средств, работающих совместно. Узлы, составляющие аппаратные средства компьютера, называют аппаратным обеспечением. Они выполняют всю физическую работу с данными: регистрацию, хранение, транспортировку и преобразование как по форме, так и по содержанию, а также представляют их в виде, удобном для взаимодействия с естественными информационными методами человека.Программное обеспечение. Программы могут находиться в двух состояниях: активном и пассивном. В пассивном состоянии программа не работает и выглядит как данные, содержательная часть которых - сведения. В этом состоянии содержимое программы можно «читать» с других программ, как читают книги, и изменять. Из него можно узнать назначение программы и принцип ее работы. В пассивном состоянии программы создаются, редактируются, хранятся и транспортируются. Процесс создания и редактирования программ называется программированием.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота