В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Boxing12474
Boxing12474
21.01.2022 22:08 •  Информатика

УСЛОВИЕ ЗАДАЧИ: написать программу, которая выводит таблицу значений функции (произвести табулирование) f(x) на заданном диапазоне X1, X2 и с заданным шагом S. Переменные X1, X2, S – вещественные. Язык программирования Delphi


УСЛОВИЕ ЗАДАЧИ: написать программу, которая выводит таблицу значений функции (произвести табулирован

Показать ответ
Ответ:
Kozlovanika71
Kozlovanika71
08.10.2020 13:25

На входе вводим с клавиатуры размерность массива: n строк и m столбцов.

Первые два вложенных цикла - это ввод двумерного массива с датчика случайных чисел randomize.

Далее во вложенных циклах ищем максимальную сумму элементов по строкам и запоминаем номер строки в переменную k.

Строку с выводом s и k писать не нужно.

Далее один цикл обмена к-той строки и последней.

Последние вложенные циклы выводят изменённый массив.

Прежде чем выводить массив нужно поставить поверку:

If k=m then write(‘Менять строки местами не нужно’) else begin и последние два вложенных цикла.


Написать программу на ! дана прямоугольная матрица размером . определить номер строки, сумма элемент
0,0(0 оценок)
Ответ:
АРИНОЧКА1111111111
АРИНОЧКА1111111111
25.07.2022 04:50

begin

var f:real->real:=x-> 0.1*(sin(x)/cos(x))*(0.1*x+0.0025*x*x);

var (a,b):=ReadReal2('Введите границы интервала:');

var (fa,fb):=(f(a),f(b));

var eps:=ReadReal('Введите требуемую точность:');

var n:=1;

var y:real;

Writeln(' n',12*' ','x',14*' ','y');  

repeat

 var x:=(a+b)/2;

 y:=f(x);

 Writeln(n:3,x:15:6,y:15:6);

 if Sign(fa)=Sign(y) then a:=x else b:=x;

 n+=1

until Abs(y)<eps;

end.

Пример:

Введите границы интервала: -1 0

Введите требуемую точность: 0.00001

n            x              y

 1      -0.500000       0.002697

 2      -0.250000       0.000634

 3      -0.125000       0.000157

 4      -0.062500       0.000039

 5      -0.031250       0.000010

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота