В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
burdyugova48
burdyugova48
27.11.2020 05:16 •  Информатика

Условие

Напишите программу, которая считает три числа и большее из них уменьшит на 5.

Формат входных данных

Вводится три различных целых числа a, b, c (−230≤a,b,c≤230−1)

Формат выходных данных

Требуется вывести новые значения этих чисел

входные данные

10 11 12

42 13 6

выходные данные

10 11 7

37 13 6

Показать ответ
Ответ:
Агентство10203040
Агентство10203040
29.11.2020 16:22

#include <iostream>

using namespace std;

signed main() {

   int a,b,c;

   cin >> a >> b >> c;

   if(a > b && a > c)

       a -= 5;

   else if(b > a && b > c)

       b -= 5;

   else if(c > a && c > b)

       c -= 5;

   cout << a << " " << b << " " << c;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота