Условный оператор. Цель работы: сформировать навыки разработки алгоритмов и программного обеспечения для обработки информации. Задачи: изучить условный оператор, разработать, отладить и протестировать программу Пусть значение y зависит от значения x. График зависимости приведен на рисунки ниже. Напишите программу на языке Паскаль, которая по заданному действительному x определит значение y.
1) program average; var i: integer; answer, S, tmp: real; begin for i := 1 to 5 do begin readln(tmp); S := S + tmp end; answer := S / 5; writeln(answer) end. 2) program equation; var A, B, C, D, x1, x2: real; begin writeln('ввеедите коэфициенты квадратного многочлена'); readln(A); readln(B); readln(C); if A <> 0 then begin D := B*B - 4*A*C; if D < 0 then writeln('действительных корней нет') else if D = 0 then begin x1 := -B/(2*A); writeln('Единственный корень: ',x1) end else begin x1 := (-B + sqrt(D)) / (2*a); x2 := (-B - sqrt(D)) / (2*a); writeln('Два корня: ',x1,', ',x2) end; end else writeln('старший коэфициент не может равняться 0') end.
program average;
var
i: integer;
answer, S, tmp: real;
begin
for i := 1 to 5 do
begin
readln(tmp);
S := S + tmp
end;
answer := S / 5;
writeln(answer)
end.
2)
program equation;
var
A, B, C, D, x1, x2: real;
begin
writeln('ввеедите коэфициенты квадратного многочлена');
readln(A);
readln(B);
readln(C);
if A <> 0 then
begin
D := B*B - 4*A*C;
if D < 0 then
writeln('действительных корней нет')
else if D = 0 then
begin
x1 := -B/(2*A);
writeln('Единственный корень: ',x1)
end else
begin
x1 := (-B + sqrt(D)) / (2*a);
x2 := (-B - sqrt(D)) / (2*a);
writeln('Два корня: ',x1,', ',x2)
end;
end
else writeln('старший коэфициент не может равняться 0')
end.
Попробуйте так:
1) 25 + 22 - 33 = 14 (учеников) - читали книги Пушкина и Лермонтова,
2) 25 + 22 - 31 = 16 (учеников) - читали книги Пушкина и Гоголя,
3) 22 + 22 - 32 = 12 (учеников) - читали книги Гоголя и Лермонтова,
4) 25 + 22 + 22 - 14 - 16 - 12+10 = 37 (учеников) - читали книги хотя бы одного из этих писателей ,
5) 40 - 37 = 3 (ученика) - не знакомы с произведениями этих писателей,
6) 25 - 16 - 14 + 10 = 5 (учеников) - читали книги только Пушкина,
7) 22 - 16 - 12 + 10 = 4 (ученика) - читали книги только Гоголя,
8) 22 - 14 - 12 + 10 = 6 (учеников) - читали книги только Лермонтова,
9) 5 + 4 + 6 = 15 (учеников) - прочли книги только одного из этих авторов.
ответ. 3 ученика не знакомы с произведениями этих писателей; 15 учеников прочли книги только одного автора.