Уточки. Как известно, при разработке и отладке программ большую могут оказать игрушечные жёлтые уточки, поэтому Денис собрал большую коллекцию жёлтых уточек. Коллекция уже настолько большая, что Денис решил расставить уточек на полки шкафа. Сначала он начал ставить на каждую полку по A уточек, но одна уточка оказалась лишней. Тогда он заново начал расставлять уточек на полки, ставя на каждую полку по B уточек, но в этом случае ему не хватило одной уточки, чтобы на каждой полке оказалось ровно B уточек. Определите минимальное число уточек, которое могло быть в коллекции Дениса.
1. А) Шахматы | теннис
2.
1) https://ps.1sept.ru/ - сайт газеты для учителя «Первое сентября»
2) https://www.admrebr.ru/ - новый сайт администрации Ребрихинского района
3) https://hermitagemuseum.org/wps/portal/hermitage/?lng=ru - официальный сайт Государственного эрмитажа
Объяснение:
1.
Чем больше ИЛИ (|) тем больше страниц будет найдено.
Чем больше И (&) тем меньше страниц будет найдено.
На кругах Эйлера в варианте А будут закрашены оба круга, в варианте Б только один из кругов, в варианте С только место, где два круга пересекаются.
2. Просто вбиваем что нужно найти в любой поисковик.
program raf105;
const
n = 10;
var
a,b,c: array[1..n] of integer;
i,j,x,max,mpos,b1,c1: integer;
begin
write('Введите максимальное число: ');
readln(x);
writeln('Заполните массив из ',n,' элементов');
for i:=1 to n do
begin
readln(a[i]);
if a[i] > x
then begin
b1:= b1+1;
b[b1]:= a[i];
end
else begin
c1:= c1+1;
c[c1]:= a[i];
end;
end;
for i:=1 to c1 do
begin
max:= -10000;
for j:=i to c1 do
if c[j] >= max
then begin
max:= c[j];
mpos:= j;
end;
c[mpos]:= c[i];
c[i]:= max;
end;
for i:=1 to b1 do
a[i]:= b[i];
for i:=1 to c1 do
a[i+b1]:= c[i];
write('Отсортированный массив: ');
for i:=1 to n do
write(a[i],' ');
end.
PascalABC 3.4.2