В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
0985440357
0985440357
15.10.2020 23:49 •  Информатика

В двух файлах записаны отсортированные по возрастанию массивы неизвестной длины. Объединить их и записать результат в третий файл. Полученный массив также должен быть отсортирован по возрастанию.
На питоне

Показать ответ
Ответ:
aidarair
aidarair
13.10.2020 23:31

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

56

57

58

59

60

61

62

63

64

65

var f1,f2,f3:text;

   n,i,a,b:integer;

begin

//создадим исходные файлы, можно вынести в отдельную программу

//или создать файлы вручную

randomize;

assign(f1,'f1.txt');

rewrite(f1);

assign(f2,'f2.txt');

rewrite(f2);

write('Сколько чисел ввести в первый файл n=');

readln(n);

writeln('Содержание файла f1:');

a:=1;

for i:=1 to n do

begin

 a:=a+random(5);

 write(f1,' ',a);

 write(' ',a);

end;

writeln;

write('Сколько чисел ввести во второй файл n=');

readln(n);

writeln('Содержание файла f2:');

a:=1;

for i:=1 to n do

begin

 a:=a+random(5);

 write(f2,' ',a);

 write(' ',a);

end;

writeln;

reset(f1);

reset(f2);

assign(f3,'f3.txt');

rewrite(f3);

//если не конец файла, то читаем числа иначе создаем барьер из

//максимально возможного целого числа

if not eof(f1) then read(f1,a) else a:=maxint;

if not eof(f2) then read(f2,b) else b:=maxint;

while (a<maxint) or (b<maxint) do//пока оба файла не кончились

begin

 if (a<=b) and (a<maxint) then //если 1<=2

  begin

   write(f3,' ',a);//1 пишем в файл 3

   if not eof(f1) then read(f1,a) else a:=maxint;//если не конец 1,

                                                 //то читаем следующее , иначе барьер

 end

 else if b<a then //иначе если 2<1 то же но со 2 файлом

  begin

   write(f3,' ',b);

   if not eof(f2) then read(f2,b) else b:=maxint;

 end;

end;

reset(f3);//смотрим что получилось

writeln('Слияние файлов:');

while not eof(f3) do

begin

 read(f3,a);

 write(' ',a);

end;

close(f1);

close(f2);

close(f3);

end.

Объяснение:

Вроде бы так, я не слишком в этом хорош.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота