В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

В массиве А(N;N) определить сумму элементов, расположенных в четных и нечетных строках. Вывести массив и обе суммы. Написать программу на C++.

Показать ответ
Ответ:
варя373
варя373
28.03.2021 12:02

Код на C++:

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

   srand(time(NULL));

   unsigned long S = 0;

   const int N = 10; //Для изменения массива изменять это число

   int A[N][N];

   for (int i = 0; i < N; i++)

   {

       for (int j = 0; j < N; j++)

       {

           A[i][j] = rand() % 100;

           cout << A[i][j] << " ";

       }

       cout << endl;

   }

   for (int i = 0; i < N; i += 2)

   {

       for (int j = 0; j < N; j++)

       {

           S += A[i][j];

       }

   }

   cout << endl << "Sum of even lines " << S << endl;

   S = 0;

   for (int i = 1; i < N; i += 2)

   {

       for (int j = 0; j < N; j++)

       {

           S += A[i][j];

       }

   }

   cout << endl << "Sum of odd lines " << S << endl;

   return 0;

}

Объяснение:

Я не знаю, какой размер у массива, но для изменения размера массива надо изменять значение константы N в коде. В первом вложенном цикле мы записываем случайное число от 0 до 99 и сразу же выводим на экран. Потом мы при первого цикла с шагом 2 (0, 2, 4, 6...) находим сумму четных строк. Второй массив для нечетных строк

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота