В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Maaaaaria122
Maaaaaria122
19.06.2022 13:00 •  Информатика

В массиве хранится информация о стоимости книг . Составить программу, которая выводит на экран номера книг, которые стоят ниже средней стоимости всех этих книг. В C++

Показать ответ
Ответ:
Dvoeschnick
Dvoeschnick
14.10.2020 23:22

#include <iostream>

using namespace std;

#define ll long long

#define ld long double

signed main(){

   ll n;

   cin >> n;

   ld a[n],sum = 0;

   for(ll i = 0; i < n; i++){

       cin >> a[i];

       sum += a[i];

   }

   ld av = sum/n;

   for(ll i = 0; i < n; i++)

       if(a[i] < av)

           cout << i+1 << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота