Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
влалллла
26.01.2023 02:23 •
Информатика
+! в одномерном массиве x(15) найти максимальный из элементов, меньше трех, и поменять его местами с предпоследним
Показать ответ
Ответ:
sidletskiy
28.07.2020 08:17
Const
N = 15;
Var
A:array[1..N]of real;
B:real;
i,j:integer;
Begin
For i:= 1 to N do
Begin
A[i]:=random(15)+2;
Write(A[i],' ')
End;
j:=0;
Repeat
j:=j+1
Until (A[j]<3)or(j=N);
if A[j]>=3 then
Begin
WriteLn;
WriteLn('В массиве нет элементов меньше 3')
End
else Begin
For i:= j to N do
if (A[i]>A[j])and(A[i]<3) then j:=i;
B:=A[j];
A[j]:=A[N-1];
A[N-1]:=B;
WriteLn;
For i:= 1 to N do
Write(A[i],' ')
End
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
taton92p08oqp
02.10.2021 06:35
Чёрно-белая без градаций серого растровое графическое изображение имеет размер 10 на 10 точек какой информационный объем имеет изображение...
матвей462
06.04.2023 01:28
Для чего нужна процедура кодирования передаваемой информации...
zwitterlord2
03.06.2021 13:19
Каждый компьютер, подключённый к интернету, получает свой уникальный 32-битовый идентификатор, называемый...
sasha10072004
03.07.2022 12:33
Сколько существует натуральных чисел x, для которых выполнено неравенство8f↓16...
Евгения1031
31.05.2021 03:25
Разработать программу для перевода оценок от «2»-«5» (от двух до пяти) то есть всего четыре оценки, их нужно перевести в буквенную формулировку, например ввожу...
erasildamir
24.05.2021 01:27
Дан одномерный массив. вывести на экран числа 5. полностью всю : program, array и т.д...
lancasterr
24.05.2021 01:27
Графикалық ақпаратты (суреттер, және т.б.) қағаздан компьютерге енгізу құралы: а)сканер в)принтер с)монитор д)пернетақта...
адамиммими1
24.05.2021 01:27
Укажите порядок подготовки и создания презентации !...
arinkachoo
26.02.2022 13:50
Расстояние от города до дачного почсёлка велесипедист проехал за 3 часа со скоростью 16км/ч. возвращаясь обратно,он то жерасстояние проехал за 4часа.скакой скоростью...
ГрознаяВафля
26.02.2022 13:50
Как это форма глагола? что в неё входит (допустим время)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
N = 15;
Var
A:array[1..N]of real;
B:real;
i,j:integer;
Begin
For i:= 1 to N do
Begin
A[i]:=random(15)+2;
Write(A[i],' ')
End;
j:=0;
Repeat
j:=j+1
Until (A[j]<3)or(j=N);
if A[j]>=3 then
Begin
WriteLn;
WriteLn('В массиве нет элементов меньше 3')
End
else Begin
For i:= j to N do
if (A[i]>A[j])and(A[i]<3) then j:=i;
B:=A[j];
A[j]:=A[N-1];
A[N-1]:=B;
WriteLn;
For i:= 1 to N do
Write(A[i],' ')
End
End.