В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
amir161
amir161
23.11.2020 11:35 •  Информатика

в паскале написать программу которая будет выводить на экран с новым годом и запрашивать информацию в ответи выводить на экран

Показать ответ
Ответ:
nikabelousova11
nikabelousova11
18.12.2022 14:16
Program yeah;const N=15;const M=15;var A:array [1..N,1..M] of integer;i,j,b,c,x,y:integer;beginrandomize;write('матрица: ');writeln;for i:=1 to N do begin   for j:=1 to M do beginA[i,j]:=random(100);write(A[i,j]:3);end;writeln;end;c:=1;while c<16 do beginfor i:=1 to N do begin   for j:=1 to M do beginb:=A[1,c];end;end;x:=x+b;c:=c+1;end;writeln('сумма первой строчки: ',x);c:=1;while c<16 do beginfor i:=1 to N do begin   for j:=1 to M do beginb:=A[15,c];end;end;y:=y+b;c:=c+1;end;writeln('сумма последней строчки: ',y);x:=x+y;writeln('общая сумма: ',x);end.
0,0(0 оценок)
Ответ:

Последовательное построение алгоритма

Существуют различные методы конструирования (разработки, построения) алгоритмов. Один из них — методпоследовательного построения (уточнения) алгоритма. Иначе он называется методом разработки «сверху вниз», нисходящим методом или методом пошаговой детализации.

Суть метода:

• задачу разбивают на несколько частей, каждая из которых проще всей задачи;

• решение каждой части задачи формулируют в отдельной команде, которая также может выходить за рамки системы команд исполнителя;

• при наличии в алгоритме предписаний, выходящих за пределы возможностей исполнителя, такие предписания вновь представляются в виде совокупности ещё более простых предписаний.

Процесс продолжается до тех пор, пока все предписания не будут понятны исполнителю.

Вс алгоритм делает структуру алгоритма более понятной.

При конкретном обращении к вс алгоритму формальные параметры заменяются фактическими параметрами, т. е. именно теми величинами, для которых будет исполнен вс алгоритм. Типы, количество и порядок следования формальных и фактических параметров должны совпадать.

Алгоритм, в котором прямо или косвенно содержится ссылка на него же как на вс алгоритм, называют рекурсивным.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота