В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sanek48rus1
sanek48rus1
24.02.2021 12:01 •  Информатика

В Питоне Напишите программу, которая моделирует работу следующего автомата. автомат получает на вход трёхзначное натуральное число и строит новое число следующим образом:
1) вычисляются суммы первой и второй, затем, второй и третьей цифр, эти суммы записываются в порядке невозрастания

Например, для числа 639 получаем сумму 6 плюс 3 равно 9 плюс 9 равно 12 результат 129. ваша программа должна принимать введённое с клавиатуры трехзначное число и определять число, которое будет получено в результате работы автомата​

Показать ответ
Ответ:
zhoha2220
zhoha2220
02.04.2023 04:35

Саша - вышивание, Маша - танцы, Валя - рисование.

Объяснение:

Либо часть про Сашу, либо про Машу ложна (два верных утверждения быть не может). Тогда либо Саша занимается вышиванием, либо Маша - рисованием.

1) Саша занимается вышиванием. Тогда Валя не может заниматься вышиванием, её часть гарантированно ложна. Значит, верно утверждение про Машу: она не занимается рисованием, ей остаются танцы. Получается, Валя занимается рисованием.

2) Маша занимается рисованием. Остается два высказывания: Саша не занимается вышиванием, Валя - занимается вышиванием. Одно из этих утверждений истинно, другое ложно. Но если истинно первое, то обе девочки не занимаются вышиванием, если истинно второе - обе занимаются. Такого быть не может, поэтому Маша не может заниматься рисованием.

0,0(0 оценок)
Ответ:
pavy1980
pavy1980
14.02.2022 04:26

string a;

string b;

int count = 0;

int count2 = 0;

bool g = false;

bool g2 = false;

Console.WriteLine("Введите первую строку");

a = Convert.ToString(Console.ReadLine());

Console.WriteLine("Введите первую строку");

b = Convert.ToString(Console.ReadLine());

Console.WriteLine("Введите первый символ");

Макрой avatar

char first_symbol = Convert.ToChar(Console.ReadLine());

Console.WriteLine("Введите последний символ");

char second_symbol = Convert.ToChar(Console.ReadLine());

char[] separ = { ' ' };

string[] a1 = a.Split(separ);

string[] b1 = b.Split(separ);

Макрой avatar

for (int i = 0; i < a1.Length; i++)

if (a1[i].IndexOf(first_symbol) == 0 && a1[i].IndexOf(second_symbol) == a1[i].Length - 1)

{

Console.Write(a1[i]+";"); count++; g= true;

}

if (g)

{

Console.WriteLine(" В этой строке :" + count + " слов(о)");

}

Console.WriteLine();

Макрой avatar

for (int i = 0; i < b1.Length; i++)

if (b1[i].IndexOf(first_symbol) == 0 && b1[i].IndexOf(second_symbol) == b1[i].Length - 1)

{

Console.Write(b1[i]+";"); count2++; g2 = true;

}

if (g2)

{

Console.WriteLine(" В этой строке :" + count2 + " слов(о)");

}

Console.ReadLine();

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота