В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lineage29201682
lineage29201682
20.01.2020 03:43 •  Информатика

В ПИТОНЕ! Напишите программу, которая выводит на экран максимальное из четырех целых чисел, введенных с клавиатуры. Используйте для написания программы словесный алгоритм.

Прежде чем писать программу, необходимо по условию задачи определить, какие данные у нас будут входными (то есть даны и будут вводиться с клавиатуры), а какие данные будут выходными (то есть представлять результат и будут выводиться на экран в качестве ответа)

В нашей задаче

ВХОДНЫЕ ДАННЫЕ: четыре целых числа через пробел

ВЫХОДНЫЕ ДАННЫЕ: одно число, максимальное из введенных

АЛГОРИТМ

1. Оформите ввод четырех значений переменных с клавиатуры

2. Присвойте значение переменной Mпервой из четырех переменных

3. Если значение второй переменной больше, чем значение, находящееся в переменной M, то замените значение переменной Mна значение второй переменной

4. Если значение третьей переменной больше, чем значение, находящееся в переменной M, то замените значение переменной Mна значение третьей переменной

5. Если значение четвертой переменной больше, чем значение, находящееся в переменной M, то замените значение переменной Mна значение четвертой переменной

6. Выведите значение переменной Mна экран

Следуя данному алгоритму, напишите программу.

Запрещенные операторы: else;and;or;not

Показать ответ
Ответ:
Alinochka1mimimi
Alinochka1mimimi
15.06.2022 13:08
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Ответ:
Дрындель
Дрындель
25.05.2021 22:02

"Я самый главный!"- заявил монитор, на мне возникает информация и изображения.

"Нет, я самая главная,- сказала клавиатура, без меня никак, не сможешь ничего оттреадактировать,вбить информацию в память, общаться - да вообще ничего!"

Но память возразила : " Ээх вы, я тут главнее всех, как вы без меня! Ничего не сохранишь, не запомнишь, да в общем без меня очень сложно что-то представить!"

"Да вы что? - начал возмущаться процессор, - Главных не должно быть, мы все представляем собой одно целое!" Так они и воссоединились и представляют собой одну частичку главного . 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота