В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ffjrppyegxvhd
ffjrppyegxvhd
25.08.2022 07:13 •  Информатика

В питоне! Ввести с клавиатуры натуральное число и найти сумму значений его цифр.
Пример:
Введите число:
1234
Cумма цифр 10
Составьте программу для питона

Показать ответ
Ответ:
Лизок892
Лизок892
14.12.2020 12:02

number = int(input("Введите число: "))

amount = 0

while number > 0:

   amount += number % 10

   number //= 10

print("Сумма цифр =", amount)

Объяснение:

number = int(input("Введите число: ")) # Ввод целочисленного значения с клавиатуры

amount = 0 # Переменная, хранящая сумму, равна 0

while number > 0: # Пока значение переменной number > 0

   amount += number % 10 # // Суммируем последнюю цифру от числа

   number //= 10 # // Отделяем эту цифру

print("Сумма цифр =", amount) # // Выводим ответ

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота