В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Антоша007
Антоша007
06.04.2023 07:01 •  Информатика

В презентации должна содержаться информация об отличиях программы Adobe Illustrator от Adobe Photoshop, сравнение растровых и векторных изображений, примеры применения программы Adobe Illustrator и изображений созданных в данной программе. В презентации обязательно должны присутствовать изображения (иконки программ, примеры растровых и векторных изображений, примеры работ созданных в Adobe Illustrator) 4 слайда

Показать ответ
Ответ:
sinjay
sinjay
12.05.2022 02:31

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   double x1, y1, x2, y2, x3, y3, a, b, c;

   

   cout << 'Введите координаты точек треугольника: ';

   cin >> x1;

   cin >> y1;

   cin >> x2;

   cin >> y2;

   cin >> x3;

   cin >> y3;

   

   a = sqrt(pow((x2 - x1), 2) + pow((y2 - y1), 2));

   b = sqrt(pow((x3 - x2), 2) + pow((y3 - y2), 2));

   c = sqrt(pow((x1 - x3), 2) + pow((y1 - y3), 2));

   

   if (a = b = c) {

       cout << "Данный треугольник - равносторонний\n";

   }

   else if (a == b || b == c || a == c ) {

       cout << "Данный треугольник - равнобедренный\n";

   }

   else if (a != b && b != c && a != c) {

       cout << "Данный треугольник - разносторонний\n";

   }

   

   if (c > a && c > b) {

       if (c*c == a*a + b*b) {

           cout << "Данный треугольник - прямоугольный";

       }

       else if (c*c < a*a + b*b) {

           cout << "Данный треугольник - остроугольный";

       }

       else {

           cout << "Данный треугольник - тупоугольный";

       }

   }

   else if (a > b && a > c) {

       if (a*a == b*b + c*c) {

           cout << "Данный треугольник - прямоугольный";

       }

       else if (a*a < b*b + c*c) {

           cout << "Данный треугольник - остроугольный";

       }

       else {

           cout << "Данный треугольник - тупоугольный";

       }

   }

   else {

       if (b*b == a*a + c*c) {

           cout << "Данный треугольник - прямоугольный";

       }

       else if (b*b < a*a + c*c) {

           cout << "Данный треугольник - остроугольный";

       }

       else {

           cout << "Данный треугольник - тупоугольный";

   }

   }

}

0,0(0 оценок)
Ответ:
galiamikhajlova
galiamikhajlova
29.03.2023 17:49

Проверенные ответы содержат информацию, которая заслуживает доверия. На «Знаниях» вы найдёте миллионы решений, отмеченных самими пользователями как лучшие, но только проверка ответа нашими экспертами даёт гарантию его правильности.

{Задача сделана на языке паскаль, при Оформление сделана как для студенческой задачи

Если есть во пиши в личку

Задача:Написать программу на языке программирования Pascal, которая вводит с клавиатуры 4 числа и выводит результат вычисления спо следующей схеме: "число1"−"число2"/"число3"+"число4"

Автор:

Дата:  }

 var  x1, x2, x3, x4: integer;

f:real;

begin

//Ввод

writeln('введите 1 число');

readln(x1);  

writeln('введите 2 число');

readln(x2);  

writeln('введите 3 число');

readln(x3);  

writeln('введите 4 число');

readln(x4); //решение

f:=(x1-x2)/(x3+x4);  

//вывод

writeln (f);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота