В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
azimjonsafu1995
azimjonsafu1995
26.05.2022 04:57 •  Информатика

В1)напишите программу,которая определяет,верно ли,что введенное число-трехзначное 2)напишите программу,которая вводит с клавиатуры номер месяца и день,и определять,сколько дней осталось до нового года.при вводе неверных данных должно быть выведено сообщение об ошибке в

Показать ответ
Ответ:
Жикабай
Жикабай
26.12.2021 04:46
1. Если число в двоичной системе заканчивается на 00, значит оно кратно 4-м в десятичной системе. То есть нужно определить, сколько существует двузначных чисел, которые в квадрате кратны 4-м.10*10
Квадрат числа будет кратен четырем в том случае, если это число чётное, то есть ответом будет кол-во четных двузначных чисел, а это 45.

2. 3 бита это 2^3 = 1 из 8 вариантов. Значит четверки - это 1/8 от всех оценок, 64/8=8 четверок

3. Всего существует 5 четных цифр (включая 0). Из них можно составить 5^4 = 625 различных четырёхзначных комбинаций.
0,0(0 оценок)
Ответ:
новенькая10
новенькая10
20.09.2020 00:39
Рекурсивный подход.(Символы тоже удаляет)
function grad(s:string):string;
var
i:byte;
detect:boolean;
begin
while i < length(s) - 2 do
begin
inc(i);
if (s[i] = s[i+1]) and (s[i] = s[i+2]) then {проверка последовательности из 3 елементов}
begin
delete(s,i,3); {если да - удаляем их}
detect:=True; {логическая переменная регистрирует изменение строки}
end;end;
if detect = True then
s:=grad(s); {если строку изменили , проверяем не появились ли там еще последовальности}
grad:=s; 
end;

var
s:string;
begin
readln(s);
writeln(grad(s));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота