В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Камилла1004
Камилла1004
10.10.2022 13:02 •  Информатика

Вам необходимо подсчитать сумму s(n) = 1 - 2 + 3 - 4 + … + (-1)n+1 *n. напишите программу, которая находит ответ за минимальное время и использует наименьший объем оперативной памяти. входные данные: одно целое число n (1 ≤ n ≤ 109) выходные данные: ответ s(n)

Показать ответ
Ответ:
asdf42
asdf42
05.10.2020 01:09
Если следовать алгоритму вычисления, представленному в формуле, то программа будет такая:

var
  n,i,s: shortint ;
begin
  write ('N=');
  readln (n);
  s:=0;
  for i:=1 to n do 
    if i mod 2 =0 
      then s:=s-i
      else s:=s+i;
  print (s)
end.

Если же посмотреть на формулу внимательно и выявить закономерность, то можно увидеть, что 

1) вычитаются только четные числа. И после каждого вычитания результат равен ровно половине вычитаемого числа (со знаком минус)
2) прибавляются только нечетные числа И прибавление идет вслед за вычитанием (кроме 1), т.е. можно к результату последнего вычитания (см.п.1) просто прибавить N.

Также учитываем, что целые числа занимают меньше памяти, чем вещественные, поэтому для программы используем самый маленький целый тип с отрицательными значениями shortint (от -128 до 127, что в данном случае нас вполне устраивает).

Помним, что значение переменной целого типа не может быть результатом деления, поэтому вместо обычного деления используем деление нацело (N div 2)

Итак:При нечетном N результат = -N div 2,
При четном N: (так как у нас целочисленное деление, то N div 2 будет равно (N-1) div 2) результат будет = -(N div 2) + N или N-(N div 2)
Т.е. вся программа сведена всего к двум операциям по разным веткам условного оператора, что сделает ее быстрее и экономичнее. К тому же не надо выделять память для переменной-счетчика.

var
  n,s: shortint;
begin
  write ('N=');
  readln (n);
  if n mod 2 =0
    then s:=-n div 2
    else s:=n-(n div 2);
  print (s)
end.

Можно увидеть и другую закономерность, что каждое сложение и идущее за ним вычитание дают одинаковый результат с разными знаками, т.е. при четном N также s=-N div 2, а при нечетном -  s=N div 2+1. Но большой разницы это не даст.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота