В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
89195188243aMils
89195188243aMils
27.06.2021 14:04 •  Информатика

Вариант № 11
I. Запишите тип переменной в Паскале
1. p3 - Целого типа;
2. r - Вещественного типа;
3. t7 - Литерного типа.

Показать ответ
Ответ:
lisnyakmashenk
lisnyakmashenk
23.12.2020 09:13
Pascal ABC Из слова "вертикаль" путем вырезок и склеек его букв получить слова "тир" и "ветка"
Ввести один из символов "Y" или "n". При вводе "Y" вывести на экран слово "Да", а при вводе "n" слово "нет" Pascal ABC 
Даны строки а="вариант",b= "Высоко", с = "макароны". Получить слово "соковарка" Pascal ABC 
 Pascal ABC Вывести текст файла, заменив цифры от 0 до 9 на слова "ноль", "один"..."девять", начиная каждое предложение с новой строки
Из слова "яблока" путем вырезок и склеек получить слово "блок" и "ока" Pascal ABC 
Pascal ABC Составить программу, которая бы выводила на экран заданное число и подпись в зависимости от числа "год", "года" или "лет"
составьте программу, которая из слова "ПРОГРАММА" составляет слова: "ГРАММ","РОГА","ГОРА"
Из слова "апельсин" путем вырезок и склеек его букв получить слово "спаниель" Pascal ABC 
0,0(0 оценок)
Ответ:
animebit81
animebit81
13.12.2021 18:02
{1}

var
  a,k,s: integer;
begin
  read(a);
  k := 0; s := 0;
  while a mod 2 <> 0 do
    begin
    if abs(a) mod 10 > 5 then
      s := s + a;
    a := abs(a);
    if (a > 9) and (a < 100) then
      k := k + 1;
    read(a);
    end;
  writeln('k=',k,', s=',s)
end.

{2}

var
  n,i,p,a: integer;
begin
  read(n);
  p := 1;
  for i := 1 to n do
    begin
    read(a);
    if (a > 0) and (a mod 3 = 0) then
      p := p * a;
    end;
  writeln('p=',p)
end.

{3}

var
  n,a,i,k,s: integer;
begin
  read(n);
  k := 0; s := 0;
  for i := 1 to n do
    begin
    read(a);
    if a > 0 then
      begin
      s := s + a;
      k := k + 1;
      end;
    end;
  if k = 0 then k := 1;
  writeln('s=',s/k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота