В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Svetlanalitv
Svetlanalitv
20.04.2022 13:18 •  Информатика

Вариант
Написать программу, которая заполняет массив случайными числами от -50 до 50, находит отрицательные числа и заменяет их на “-1”.
Программа вычисляет сумму элементов массива, кратных 5.

Все в Pascal*

Показать ответ
Ответ:
nazar221
nazar221
07.06.2022 00:42
 const nx = 20;
var x: array[1..nx, 1..nx] of integer;z:array[1..nx*2] of integer; 
i, j, k,n,r,t: integer; 
begin 
Writeln('Введите размер матрицы n');Read(n); 
 for i := 1 to n do begin   
for j := 1 to n do begin   
Read(k);x[i, j] := k;  end;end;   
Writeln('Исходный массив'); 
for i := 1 to n do begin   
for j := 1 to n do begin     
Write(x[i, j]:4);     
if x[i, j]>0 then begin t:=t+1; z[t]:=x[i, j];end;    
end;   
Writeln;  end; 
Writeln;Writeln('Одномерный массив'); 
for j := 1 to t do     
Write(z[j]:4); 
 end.
0,0(0 оценок)
Ответ:
Tolganay11
Tolganay11
05.04.2022 04:43
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var n:=ReadInteger('Количество элементов в массиве: ');
  var a:=ArrRandom(n,-50,50);
  a.Println(',');
  Writeln('Четные элементы: ');
  var i:=1;
  while i<n do begin Write(a[i],' '); Inc(i,2) end;
  Writeln;
  Writeln('Нечетные элементы: ');
  i:=0;
  while i<n-1 do begin Write(a[i],' '); Inc(i,2) end;
  Writeln
end.

Тестовое решение:
Количество элементов в массиве:  10
15,-18,-29,-25,46,21,-8,-17,-9,15
Четные элементы:
-18 -25 21 -17 15
Нечетные элементы:
15 -29 46 -8 -9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота